Caption file VTT is not existing

Hi Everyone,

I'm using Lectora desktop 18, and I'm trying to add a VTT caption file to a video, but Lectora's drop down menu does not show the VTT file. It only shows the xml version of the file. Did I do something wrong? Please see the screenshot below.

Thank you,


Discussion (9)

Thank you Adam. I'm so sorry I cannot share my file, but the screenshot shows the screen when I click on Browse for File in Add Captions menu.

Actually, the captions created in the xml file appear when in the Run and Preview modes, but when I publish it, they don't appear. I thought I can replace the xml file with the vtt but I cannot find the vtt file.

Thanks for any tip.


In Windows file explorer, navigate to the folder where the VTT file is located. Make sure it is not saved with a txt extension which can happen when vtt files are editied in notepad. So look for "YourFileName.vtt.txt". This would keep our Browse For file window from seeing the vtt file, as its actually a txt file. You might have to modify your windows explorer options to turn on "Show File name extensions".

If that checks out okay, in the Browse for File window, expand the file names column to see the actual extensions of the files. The windows "Type" could be reporting the vtt as a xml due to a misconfiguration, but we can't tell in the current screen shot waht the real file names are.

are you able to drag/drop the file onto the module?

I'm sorry, I forgot to attach a sample of the VTT file. Here it is


Thank you John. Actually, the file extension is saved right, however in Browse for File Window, the file name is Lesson1.vtt but the type is text (please see attached image). Could that be the cause?


Therese and I worked this issue outside of the forum. We still are working on other issues, but this particular one was resolved. The file name extension had .txt at the end after the .vtt, Lesson1.vtt.txt. This is why the Lectora Caption File browser was not able to see the file as it was only looking for vtt, xml and srt extensions.

... and I speculate that Therese's computer is set to hide known file extensions, so she couldn't see the .txt?

Not that I have done customer support or anything ....

I don’t know why I’m not getting the notifications via email recently.

For the same reason this forum is only copyrighted through 2017?

Hi Carl,

I'm sorry for my late response. I don't know why I'm not getting the notifications via email recently.

Anyway, your guess was right, but thanks to John, I was able to see it.

Thanks for the follow up though!


Discussions have been disabled for this post