Tap / click here to continue

Hello - I am now getting this message every time I have an autoplay requirement on my slide in the Debug and Preview options, and once I click the message, it loads.

Is there a way to disable this message from appearing? It didn't appear in the Lectora 19.0.1 version of the software. Will this happen when I load it into my LMS?

Discussion (18)

Hey, Andrew - this just in from our Product Dev team:

For run mode it should not do this, we will address that. For Preview in Browser and in your LMS it will display the Tap / Click page if the Browser does not allow auto-play. Most desktop browsers switched to not allow auto-play for audio (or video audio tracks) until the user interacts with the webpage.

Lectora-published content checks to see if it's able to auto-play media, if not then it presents the Tap / Click here page (if there is media on the page set to auto-play).

For desktop browsers you really should only see this once. Please let us know if you are seeing it for every page in your published content. In the meantime, we'll see what's going on for run mode that would be frustrating. Thank you for reporting this issue.

How to disable it: (last entry)


Thank you for reporting this issue. We understand your concerns on the behavior of Tap/Continue with desktop browsers for titles built in Lectora version 19.0.4. We have determined that this is an issue with the software and have submitted this to our product team for their consideration with tracking ID LD-7629, however please know that there is no estimation of when this will be addressed.

To work around this issue, we recommend that you publish with Seamless Play (Publish process, HTML Options tab), which will not prompt desktop browsers, and will only prompt mobile users the first time, as expected. The other work around, especially if using the Web Accessible Title Option, is to not use autoplay on videos. According to many experts, while auto play videos are an annoyance for people without disabilities, for people with disabilities, autoplay can make a site unusable. Please see the following article that explains some of the issues autoplay can cause for people with some disabilities.


We apologize for this inconvenience, but we assure you that our team is working to provide a solution as soon as possible.

Data point: I turn off all video and audio autoplay in all my browsers.

I hate it. It uses bandwidth, largely for stuff I don't want. I'd much rather click once to view video than have every commercial site stick those annoying video popups at the bottom of my screen, or autoplay a video version of a news story when I just want to read the text.

@andrew-robertson that code snippet will skip the Tap/Click page cover that prompts the user to click and allow for auto-play to work. The Tap/Click page should only display in situations where auto-play is not allowed by the browser (we test for it).

Thank you for your responses, feedback, and suggestions.

While my junior developer raised the issue to me, I was able to upload to my test LMS and launch it in our three browsers (IE11, Edge Chromium, and Chrome) without issues.

I am now wondering if I should add the code that @RichVass suggested to plan for the future (ie. if our IT dept decides to disable autoplay OR if we start providing content outside of our controlled IT environment). I am not a web-dev pro by any sorts, but what does this code essentially do? Does it simply "auto-click" the Tap / Click here to continue message?

The nice thing is that we are in a corporate environment, and our user workstations are heavily locked down. And the even nicer thing is that these workstations where 90% of our content is consumed from are locked down to a point where you cannot even browse the web. So I will dig some more and see what we can do internally and maybe do something with the autoplay feature(s).

edit: more details

Thanks @wheels for your response. So I guess we are simply suppressing the message and that audio/video will continue to play if we have it set to auto-play?

Are there any limitations/exceptions that we should be aware of?

Glad to help, Andrew. @wheels , will you take a look at Andrew's comment about the getDisplayWindow code (above). Is he thinking about this right?

For desktop browsers you really should only see this once. Please let us know if you are seeing it for every page in your published content.

I just tested a course on SCORM Cloud and it's prompted this for every single page. I added the workaround code and it appears to have fixed the issue. I'm fortunate it did, because I specifically designed my course to not autoplay *only* for screenreader users. It would be a real shame to have a future update that forcibly overrides a custom solution.

The message is being presented because it requires user interaction to enable auto-play. If you suppress the tap/click the content will not auto-play.

Please email lectora.support@elearningbrothers.com and if you can provide a link to the content and tell them what browser you are using it would help us a lot. It should not be presenting the tap/click page every page on a desktop browser. The only case that behavior is expected is on a mobile device where it was not published with the seamless play option. Thanks, sorry for the inconvenience, but our support team will get this straightened out.

I will re-check the logic we are using and in the meantime you can disable the tap/click if it provides a better experience.

How to disable it: (last entry)


Thank you for reporting this, we confirmed it is a problem with v19.0.4. The easiest way to work around this is to add the file blank.mp4 into your title.

You can add it anywhere in your title and it can be hidden. This will put the file in your published directory and will fix this issue.

I'm attaching the file here, get it and put it in your title. This will be fixed in v21 and v19.0.5 when they are released.


(blank.mp4 is also in the Lectora installation directory "Lectora 19\Support Files")


Unless you publish using the Seamless Play option Firefox will ask on each page (if you have auto-start enabled on media).

Chrome allows auto-start after the user interacts with the website. Firefox allows auto-start after the user interacts with the current page.

We will continue to monitor this behavior and will provide a fix if we are able to.


We have added the blank.mp4 file to our titles, but the issue still exists for users going thru our modules via Firefox. Do you have a workaround for that? Also, is there any timeframe for when this will be fixed?


The Tap/Click page should only display in situations where auto-play is not allowed by the browser (we test for it).

I researched how to test for it, so I could include some JS of my own to find out if autoplay is not allowed. But since you're already testing for it, as you said here, it sure would be nice if we could just check the value of an existing Lectora variable instead! Is there currently a variable that we could check to determine if the browser allows autoplay or not? I know there currently isn't a Reserved variable for this, but perhaps one that could be accessed via JS? (I'm already disabling the big grey play button via the JS you provided elsewhere, which works great! So thank you for that!!! :-)

BTW, none of my media is set to Auto Start because I have actions in place to check if a user tap/click is needed (checks for iOS via Platform var, which is what I want to change). However, the big grey play button still shows up regardless if there is any media on the page that contains audio. ??? I'm currently using version 21.0.3.

@wheels - I sent a sample to the support team. The issue of the big play button showing up isn't really an issue for me now that I am using the script to disable it (I removed the script from the sample I sent to support). However, I (and probably some others here) would like to have an easier way to detect if autoplay is disallowed on the current browser or not. So is there an internal Lectora variable that we can check via JS? If you're testing for it, I'm guessing there must be something in there! :-)

@possumneck can you you post your project here, or make a similar project where you see the same behavior. That is really strange if you don't have autostart set on anything in the project, and no background music. If that it too much work and you don't want to post your work here please contact support@elblearning.com and they will take a look. Reference this post.

Hi @possumneck thank you for submitting the sample, that will help us.

Because autoplay it's a state of the browser environment we cannot store it in a variable. Instead we check with some code. I would suggest you use the latest method which can be found in this stackoverflow post.

Thanks so much @wheels I'll check it out! :)