Issue with move actions

Hey all! I'm back at working with Lectora finally after a LONG haul with Canvas and a touch of Articulate. And of course, I manage to find a quirk I can't overcome and seeking some help! This one has some weird layers, so I'll try and explain best I can, but am also including an example.

I have 5 buttons on a page organized vertically. Button 1 is always in its initial position. When you click Button 1, the 4 buttons below it move down together in the same vertical order. Each button should move the buttons below it to those positions. Then, clicking one of the buttons at the bottom moves it AND all buttons above it back to their initial position, etc., etc.

I'm using the "move" function, and it works initially with each button. The problem is that it doesn't take much to break the overall functioning, depending on how you click around and I cannot figure out why. I even briefly tried using a variable to set the "position" to top or bottom, then making the move conditional on it's positioning.

Is this something with the move function, something with variables, or simply a time thing where I need to put a short delay on the moves? I'm stumped, so any help is welcome!

Discussion (10)

Quick update - after more experimentation, the move actions work correctly provided I use variables to set whether a button is "up" or a button is "down" with an onClick. I initially tried setting a variable to the value and using that in the Move action, but it still didn't work. Not the most ideal scenario, but perhaps something for support or developers to look into further to see why a simple Move doesn't work, as far as I can tell.

Thank you for posting this example. Your example is simple and straight forward, and it works in Lectora Online as expected. We will take a look at why it is not working and we will fix it for v21, sorry for the inconvenience it has caused you.

- Joe

Hey Tim - Thanks for looking at it. That's the behavior I saw as well - as soon as you add the third button, it eventually would "crash" and I couldn't nail down what specific combination caused it to break, if there even was one in particular.

Using a variable ended up working well - Each button was initially assigned its own variable with a default value of "up". When the button moved to the bottom, that value was changed to "down". Then, I set the "moves" to trigger only if the variable was "down". So far, I haven't been able to break it again, and this time it's with 8 buttons. Thank goodness for action groups and groups in general, because there's a set of images and other buttons that are shown or hidden based on each one.

This has been fixed for v21 and if you would like the fix for previous release please contact support. Thanks again for posting your issue with a reproducible example.

It seems the error occurs when a button is told to move by an action but cannot move because it already is in its target position.

When you click button 1 it works, the other 4 move down. If you then click button 2, it will move up as expected, but if you later click button 3 the whole system will break because buttons 3,4,5 haven't moved after the click on button 2.

Please contact support, they will have the patch file and instructions on how to apply it.

@wheels any chance I can get that fix for version 19?

This is very nice information, Thanks for sharing.

Desktop Technicians

The error seems to occur when the button receives a command to move, but cannot move because it is already in its target position. When you press button 1, it works, the other 4 move down. If you then press button 2 it will move upwards as expected, but if you later press button 3 the whole system will break because the 3,4,5 buttons did not move after pressing button 2.

We will be releasing v19.0.4 this week, and it includes the fix for this.