Multiple Choice Question ignores all mouse clicks ... most of the time?

A colleague of mine created an e-learning using Publisher 17.0.6. In the Preview mode, the "Knowledge Check" (a simple multiple choice question) works fine. Click on wrong answers, get negative feedback. Click the right answer, get positive feedback and an audio cue, and the Next button appears.

In any browser, whether published or in preview, it works some of the time (15%?) and clicks do absolutely nothing the rest of the time. We tested in IE11, Chrome (latest) and Firefox ESR.

Has anyone else experienced this? I haven't dug into her actual course yet (for one thing, we're working many miles apart today). I'm just wondering if there's some obvious thing I am missing.

Discussion (7)

Nothing I can think of specifically - the only thing I can think of that I've seen in the past with that type of scenario is some layering issue. (something partially covering the response), so sometimes when the user clicks, they are actually clicking on the response bubble/text, and sometimes the clicking is happening on top of a layer of something else.

Only thing I personally can think of off-hand that would have this type of intermittent error, and not related to a 'max attempt' limit on answering the question.

Not in recent version of Lectora - but in the past I've seen some issues with questions in general that could be solved by simply re-creating the question from scratch instead of modifying a current question that had problems with it - is that an option?

I've fixed layering issues in the past myself, @Adam. We did check for this and found nothing, and I tried zooming in and out, clicking all over the page at random, and also using Tab to try to put the focus on hidden controls.


When exactly does it stop working? Do you have any transitions going on? There are some bugs in 17.0.6 concerning transitions.

As this works 15% of the time, the functions are probably fine.

The fact that you have an audio cue and then the Next button appears suggests that there is a transition, or other action, that displays the Next button. This suggests then, that you are clicking the Next button before the transition completes.

You can test this by waiting several seconds before pressing Next to see the success rate. undefinedIf this [always] works, then there is a transition on the one of the objects on the page that is not completed prior to pressing the button.

Any chance you can copy this question to an fresh .awt file and upload? I'm really curious now...

Interesting thoughts, John, but the cue to play the audio is answering the question correctly. No amount of waiting matters. There are zero transitions in this course.

Discussions have been disabled for this post